Older Mac OS X Tech Support - 10.2, 10.3, 10.4

Game of universal domination. New dice available free upon request.
Post Reply
User avatar
dustin
Lux Creator
Lux Creator
Posts: 10315
Joined: Thu May 15, 2003 2:01 am
Location: Cascadia
Contact:

Older Mac OS X Tech Support - 10.2, 10.3, 10.4

Post by dustin » Sat Jan 22, 2011 5:54 pm

First, you need to run Software Update (available from the System Preferences in the Apple menu) and install any MacOS and Java updates that are there.

You should also make sure that you are using the most recent version of the game.

If there's still a problem:
Mac OS X 10.2 users should read this.

Mac OS X 10.3 users can try manually installing the last Apple Java update.

Mac OS X 10.4 users should open the Java Preferences application located in
/Applications/Utilities/Java/J2SE 5.0/ and switch J2SE 1.4.2 or J2SE 1.5 around in the list so the other one is on top.
Last edited by dustin on Tue Jan 12, 2016 5:48 am, edited 2 times in total.

User avatar
paranoiarodeo
Semiholy Tyrant
Posts: 10421
Joined: Sun Jul 17, 2005 5:30 pm

Post by paranoiarodeo » Sat Jan 22, 2011 6:21 pm

Also I could be totally wrong about this but ...

Lux 6.0 includes some code that no longer works with (some? all?) G3 processors ...

(My first Lux comp — sage iMac from summer 2000 — bounces the dock icon then refuses to launch with no error dialog.)

Just sayin' this 'cause folks with old versions of OS X often have old hardware too ...

∞ paranoiarodeo ymmvs ∞

Errorik
Lux Newbie
Posts: 1
Joined: Wed Jan 11, 2012 4:51 pm
Location: Eden Prairie

close, but no world domination

Post by Errorik » Wed Jan 11, 2012 5:51 pm

The java version switch does not fix the opening Lux or Castle Vox problem with my G3. I am running 10.4.8 with the current java versions. 10.4.11 is incompatible with my ZIF 1.1 GHz CPU upgrade.

Lux opens fine on my slower G4 running 10.4.11. It also opened before I did the combined 10.4.11 update.

I would be nice indeed if the fix was this simple. My circumstance does lead me to believe it is a CPU specific issue.

Perhaps a G3 specific version would give these system more usefulness and longevity. Similar to what Camino has done with making a G3 specific web browser. It would not need to be a full featured version. If it allowed Lux and Castle Vox to play AI on this ol' box, that would be enough.

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests