overground question -- please help!

Lux maps won't make themselves.
Post Reply
User avatar
Kartofile
Luxer
Posts: 255
Joined: Sat Jun 17, 2006 1:30 am

overground question -- please help!

Post by Kartofile » Mon Jun 19, 2006 6:25 pm

Hi, I'm working on my first map and trying to add an "overground."

I've made an image with some little ships in the middle and the rest of the field is white. But when I go into Lux, it doesn't understand that I want the white areas to be see-through, and so the whole screen goes white. Could anyone tell me how to save the overground image so that the white areas are see-through?

Thanks!

User avatar
Preacherman
Semiholy Priest
Posts: 4496
Joined: Tue Feb 24, 2004 3:52 am
Location: Sweden (capital of Denmark, an island in Norway, southern Europe)
Contact:

Post by Preacherman » Mon Jun 19, 2006 7:05 pm

Hi Kartofile,
Lux uses .png images to show transparency - you will need to make sure your image is saved in this format, the white area you have now needs to be transparent in Photoshop, and saving at as .png will retain this in the Lux application.

∞ preacherman is sure that there is a more elegant way of saying all that but is too inebriated to figure it out ∞

User avatar
Kartofile
Luxer
Posts: 255
Joined: Sat Jun 17, 2006 1:30 am

Post by Kartofile » Mon Jun 19, 2006 9:36 pm

Thanks, Preacherman. I think I'm closer than I was before...

I've saved it as a .png image called "overground.png" and the white area is now definitely transparent when I save the image. So that's a good thing.

But when I go into Lux it still comes out all white... :( Any ideas?

User avatar
Kartofile
Luxer
Posts: 255
Joined: Sat Jun 17, 2006 1:30 am

Post by Kartofile » Tue Jun 20, 2006 12:45 am

OK, it works now. I opened up the original .png with a different application and then did "Save As..." another .png... I have no idea why it worked but I'm not complaining. :)

User avatar
Preacherman
Semiholy Priest
Posts: 4496
Joined: Tue Feb 24, 2004 3:52 am
Location: Sweden (capital of Denmark, an island in Norway, southern Europe)
Contact:

Post by Preacherman » Tue Jun 20, 2006 4:26 am

Good man - look forward to seeing the map :)

User avatar
Kartofile
Luxer
Posts: 255
Joined: Sat Jun 17, 2006 1:30 am

Post by Kartofile » Wed Jul 19, 2006 3:40 am

And... one month later... I finally got around to uploading it. :roll:

CSE
Lux Newbie
Posts: 4
Joined: Mon Aug 17, 2009 3:25 pm
Location: Switzerland

Post by CSE » Mon Aug 24, 2009 4:06 pm

Kartofile wrote:OK, it works now. I opened up the original .png with a different application and then did "Save As..." another .png... I have no idea why it worked but I'm not complaining. :)
For those it may help: same happened to me.
On the Mac, the easiest solution is to open the .png with "Preview" (built in MacOS) and "save as..." from there. Then the transparency works fine (which it did not using e.g. Graphics Converter).

Post Reply